Конфигурирование протокола RIP (рабочая конфигурация) | NetConfig

Конфигурирование протокола RIP (рабочая конфигурация)

В этой статье мы рассмотрим пример конфигурации протокола RIP без поддержки бесклассовых масок подсетей.
Вначале , для понятности адресации, мы обратим внимание  на нижеприведенную таблицу.Здесь у  интерфейсов Router5 первые адреса приведенных сетей, а у маршрутизаторов, подключенных к Router5 -вторые.Со стороны локальной сети маршрутизаторы имеют последние адреса, допустимые  в сетях.Ноутбуки и компьютеры  получили первые адреса в своих сетях.


Итак, приступаем к конфигурации роутеров!

Команда router rip предоставляет возможность конфигурировать протокол rip на Cisco routers.

Команда network активизирует интерфейс для работы с данным протоколом, а также позволяет объявить сети, непосредственно подключенные к маршрутизатору.

Команда ip address позволяет назначить ip address на интерфейс, а no shutdown включает его.

Router1:

Router(config)#hostname R1
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 200.0.0.2 255.255.255.252
R1(config-if)#no shutdown
R1(config)#interface fastEthernet 0/1
R1(config-if)#ip address 10.0.255.254 255.255.0.0
R1(config-if)#no shutdown
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 200.0.0.0

Router2:

Router(config)#hostname R2
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 155.0.0.2 255.255.255.252
R2(config-if)#no shutdown
R2(config)#interface fastEthernet 0/1
R2(config-if)#ip address 20.0.0.254 255.255.255.128
R2(config-if)#no shutdown
R2(config)#router rip
R2(config-router)#network 20.0.0.0
R2(config-router)#network 155.0.0.0

Router3:

Router(config)#hostname R3
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 50.0.0.2 255.255.255.252
R3(config-if)#no shutdown
R3(config)#interface fastEthernet 0/1
R3(config-if)#ip address 192.168.30.254 255.255.255.0
R3(config-if)#no shutdown
R3(config)#router rip
R3(config-router)#network 50.0.0.0
R3(config-router)#network 192.168.30.0

Router4:

Router(config)#hostname R4
R4(config)#interface fastEthernet 0/0
R4(config-if)#ip address 100.0.0.2 255.255.255.252
R4(config-if)#no shutdown
R4(config)#interface fastEthernet 0/1
R4(config-if)#ip address 172.16.0.62 255.255.255.192
R4(config-if)#no shutdown
R4(config)#router rip
R4(config-router)#network 10.0.0.0
R4(config-router)#network 200.0.0.0

И наконец приступим к центральному роутеру!Стоит отметить ,что эта схема нормально работала бы и с
одним – центральным маршрутизатором, но для наглядности примера конфигурации я решил сделать
несколько сложнее конфигурацию, но если к крайним маршрутизаторам подсоединить еще по паре сетей,
то для снижения нагрузки подойдет лучше именно эта конфигурация.А для отказоустойчивости сети можно
сделать полносвязную топологию, что хорошо скажется на распределении маршрутов, снижении нагрузки,
и в данном случае на выборе наиболее короткого маршрута в сеть назначения, ведь именно число
переходов протокол rip использует в качестве метрики при выборе оптимального маршрута.
Итак конфигурация :

Router5:

Router(config)#hostname Center
Center(config)#interface fastEthernet 0/0
Center(config-if)#ip address 200.0.0.1 255.255.255.252
Center(config-if)#no shutdown
Center(config)#interface fastEthernet 1/0
Center(config-if)#ip address 155.0.0.1 255.255.255.252
Center(config)#interface fastEthernet 8/0
Center(config-if)#ip address 100.0.0.1 255.255.255.252
Center(config-if)#no shutdown
Center(config)#interface fastEthernet 9/0
Center(config-if)#ip address 50.0.0.1 255.255.255.252
Center(config-if)#no shutdown
Center(config)#router rip
Center(config-router)#network 50.0.0.0
Center(config-router)#network 100.0.0.0
Center(config-router)#network 155.0.0.0
Center(config-router)#network 200.0.0.0

Команда show ip protocols показывае какие протоколы динамической маршрутизации сконфигурированы и какие параметры настрояны для них.
Ниже приложена лабораторная, где все это сконфигурировано.


Для правильной работы со схемами необходима версия Packet Tracer 5.3.2


Тэги: , , , , ,



2 Responses to “Конфигурирование протокола RIP (рабочая конфигурация)”

  1. Александр 10. Jun, 2011 at 10:17 #

    Анатолий, с РИПом имею дело давно и сконфигурировать сложные сети, по сути не доставляет проблем 😉 статья хорошая , но вот у меня вопрос , хотя возможно оффтом, немогли бы вы связаться со мной по вопросу пинга между подсеть1 и подсетью3 по такой схеме:
    “подсеть1 + cisco881 + подсеть2 + cisco881 + подсеть3”
    Компьютеры WinXP подсети1 не могут получить ICMP ответ всех компьютеров WinServ2008 подсети3 , при этом пинги в разные стороны между машинами других операционных систем летают без проблем

  2. Гапон Анатолий 10. Jun, 2011 at 19:48 #

    Здраствуйте Александр, На первый взгляд – проблема в персональном фаерволе одной из этих машин. Если же нет, то предоставте более подробную информацию, или свои контакты.

Оставить комментарий


iTuts dakulov Free CDN NetConfig