Базовая настройка OSPF в сети Point-to-Point | NetConfig

Базовая настройка OSPF в сети Point-to-Point

Настройка протокола OSPF (Open Shortest Path First) на данной схеме достаточно проста.

Это настройка для сети типа POINT-TO-POINT, то есть  на сериальных каналах. Перейдем непосредственно к конфигурации:

Сначала перейдем на роутер Branch1 и в режиме глобальной конфигурации (Branch1(config)#) вводим следующие команды:

(Branch1(config)#)  router ospf 1

– единица  это номер процесса на роутере и на роутерах одной области может отличаться.

Далее получаем меню режима глобальной конфигурации на настройку протокола OSPF.

Branch1(config-router)#

теперь здесь необходимо объявить все непосредственно подключенные сети. Если объявить не подключенную сеть (произвольную) то она не войдет в рассылаемую информацию о сетях этим маршрутизатором

Branch1(config-router)# network 20.0.0.0 0.0.0.3 area 0

– 0.0.0.3 ето wildcard mask (перевернутая маска), area 0 это номер области, и на всех маршрутизаторах одной области он должен быть одинаковый.

Branch1(config-router)# network 20.0.0.12 0.0.0.3 area 0
Branch1(config-router)# network 20.0.0.12 0.0.0.3 area 0
Branch1(config-router)# network 192.168.0.0 0.0.0.128 area 0

И по этой аналогии на всех маршрутизаторах данной схемы необходимо объявить все непосредственно подключенные сети.

Тип сети в которой работает протокол можно посмотреть командой:

Branch1#sh ip ospf interface название интерфейса. Например

Branch1#sh ip ospf interface s 0/0/0

Вывод команды:

Serial0/0/0 is up, line protocol is up
Internet address is 20.0.0.1/30, Area 0
Process ID 1, Router ID 192.168.0.126, Network Type POINT-TO-POINT, Cost: 64
Transmit Delay is 1 sec, State POINT-TO-POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Если все сделано правильно, то running-config должен быть таким же как приведенный ниже.

Конфигурация Branch1:

!
interface FastEthernet0/0
ip address 192.168.0.126 255.255.255.128
duplex auto
speed auto
!
interface Serial0/0/0
ip address 20.0.0.1 255.255.255.252
!
interface Serial0/0/1
ip address 20.0.0.14 255.255.255.252
!
router ospf 1
log-adjacency-changes
network 20.0.0.0 0.0.0.3 area 0
network 20.0.0.12 0.0.0.3 area 0
network 192.168.0.0 0.0.0.127 area 0

Конфигурация HQ:

!
interface FastEthernet0/0
ip address 192.168.0.158 255.255.255.224
duplex auto
speed auto
!
interface Serial0/0/0
ip address 20.0.0.2 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 20.0.0.5 255.255.255.252
clock rate 64000
!
router ospf 1
log-adjacency-changes
network 20.0.0.4 0.0.0.3 area 0
network 192.168.0.128 0.0.0.31 area 0
network 20.0.0.0 0.0.0.3 area 0
!

Конфигурация Branch2:

Конфигурация Branch2:

!
interface FastEthernet0/0
ip address 192.168.0.174 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0/0
ip address 20.0.0.9 255.255.255.252
!
interface Serial0/0/1
ip address 20.0.0.6 255.255.255.252
!
router ospf 1
log-adjacency-changes
network 20.0.0.8 0.0.0.3 area 0
network 192.168.0.160 0.0.0.15 area 0
network 20.0.0.4 0.0.0.3 area 0
!

Конфигурация Branch3:

!
interface FastEthernet0/0
ip address 192.168.0.254 255.255.255.192
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.190 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0/0
ip address 20.0.0.10 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 20.0.0.13 255.255.255.252
clock rate 64000
!
router ospf 1
log-adjacency-changes
network 192.168.0.176 0.0.0.15 area 0
network 192.168.0.192 0.0.0.63 area 0
network 20.0.0.8 0.0.0.3 area 0
network 20.0.0.12 0.0.0.3 area 0
!

Для правильной работы со схемами необходима версия Packet Tracer 5.3.2


Тэги: , , , , ,



Пока нет комментариев.

Оставить комментарий


iTuts dakulov Free CDN NetConfig