Настройка протокола EIGRP | NetConfig

Настройка протокола EIGRP

Настройка протокола маршрутизации EIGRP (Enhanced Interior Gateway Routing Protocol) для данной схемы достаточно простая, но все же потребуется немного времени для ее настройки.

Первое что нужно сделать, так это перейти в режим глобальной конфигурации командой configure terminal, далее необходимо сделать следующее:

Branch1(config)#
Branch1(config)# router eigrp 1

– 1 это номер автономной системы, на всех роутерах одной автономной системы он должен быть одинаковый.

Branch1(config-router)#

– теперь необходимо  объявить непосредственно подключенные сети.

Branch1(config-router)# network 20.0.0.0

– после адреса сети можно добавить wildcard mask, но это не обязательно потому, что маску сети протокол возьмет с интерфейса в этой сети. Если объявить сеть в которой данный маршрутизатор не имеет активных интерфейсов, то такая сеть не войдет в информацию об обновлении маршрутов. Так же если у маршрутизатора 2 и более интерфейса в разных подсетях одной классовой сети, то не обязательно объявлять эту подсеть дважды. Например как на нашей схеме у маршрутизатора Branch1 2 serial интерфейса в разных подсетях, но в одной классовой сети, и можно не объявлять 2 подсети, а объявить одну сеть, как и сделано.

Далее необходимо отключить автосуммирование:

Branch1(config-router)#no auto-summary

– это нужно для того, что бы маршрутизатор принял информацию о подсетях сети 20.0.0.0, по умолчанию автосуммирование включено и производится на границе сети, в таблице маршрутизации вместо сетей 20.0.0.8 и 20.0.0.4 будет

20.0.0.0/8 is a summary, 00:00:01, Null0

– и 2 непосредственно подключенные сети 20.0.0.0 и 20.0.0.4. Вид таблицы маршрутизации

Gateway of last resort is not set
20.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
<strong>D       20.0.0.0/8 is a summary, 00:00:01, Null0</strong>
C       20.0.0.0/30 is directly connected, Serial0/0/0
D       20.0.0.4/30 [90/2681856] via 20.0.0.2, 00:00:02, Serial0/0/0
D       20.0.0.8/30 [90/2681856] via 20.0.0.13, 00:00:04, Serial0/0/1
C       20.0.0.12/30 is directly connected, Serial0/0/1
192.168.0.0/24 is variably subnetted, 6 subnets, 5 masks
D       192.168.0.0/24 is a summary, 00:00:02, Null0
C       192.168.0.0/25 is directly connected, FastEthernet0/0
D       192.168.0.128/27 [90/2172416] via 20.0.0.2, 00:00:02, Serial0/0/0
D       192.168.0.160/28 [90/2684416] via 20.0.0.13, 00:00:04, Serial0/0/1
[90/2684416] via 20.0.0.2, 00:00:02, Serial0/0/0
D       192.168.0.176/28 [90/2172416] via 20.0.0.13, 00:00:04, Serial0/0/1
D       192.168.0.192/26 [90/2172416] via 20.0.0.13, 00:00:04, Serial0/0/1

Но при отключении автосуммирования все становиться на свои места.

По данному примеру конфигурируются все остальные маршрутизаторы на схеме.

Если все сделано правильно, то:

Branch1 running-config

interface FastEthernet0/0
ip address 192.168.0.126 255.255.255.128
duplex auto
speed auto
!
interface Serial0/0/0
ip address 20.0.0.1 255.255.255.252
!
interface Serial0/0/1
ip address 20.0.0.14 255.255.255.252
!
router eigrp 1
network 20.0.0.0
network 192.168.0.0
no auto-summary
!
HQ running-config
interface FastEthernet0/0
ip address 192.168.0.158 255.255.255.224
duplex auto
speed auto
!
interface Serial0/0/0
ip address 20.0.0.2 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 20.0.0.5 255.255.255.252
clock rate 64000
!
router eigrp 1
network 192.168.0.0
network 20.0.0.0
no auto-summary
!

Branch2 running-config

!
interface FastEthernet0/0
ip address 192.168.0.174 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0/0
ip address 20.0.0.9 255.255.255.252
!
interface Serial0/0/1
ip address 20.0.0.6 255.255.255.252
!
router eigrp 1
network 192.168.0.0
network 20.0.0.0
no auto-summary
!

Branch3 running-config

!
interface FastEthernet0/0
ip address 192.168.0.254 255.255.255.192
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.190 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0/0
ip address 20.0.0.10 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 20.0.0.13 255.255.255.252
clock rate 64000
!
router eigrp 1
network 192.168.0.0
network 20.0.0.0
no auto-summary
!

Для правильной работы со схемами необходима версия Packet Tracer 5.3.2


Тэги: , , , , , ,



One Response to “Настройка протокола EIGRP”

  1. Dave 01. Feb, 2011 at 15:31 #

    Нашел для себя интересные статьи, которые мне помогут в самостоятельной подготовке к сертификационному экзамену Cisco CCNA.
    Вот только немного глаз “режет”, что в этой лабораторной ( или практическом примере ) используются адреса не входящие в диапазоны немаршрутизируемых сетей ( RFC 1918 ). Это конечно же просто пример, но все таки.
    А так очень хорошее качество материала и самого ресурса. И дизайн приятный.

Оставить комментарий


iTuts dakulov Free CDN NetConfig