Маршрутизация между vlans | NetConfig

Маршрутизация между vlans

В этой статье описывается пример маршрутизации между vlans ,другими словами это называется настройка router one a stick , с помощью sub-interfaces на маршрутизаторе . Как известно , vlans позволяют легко управлять отдельными областями сети и повышают безопасность , хочу напомнить что по умолчанию все порты коммутатора находятся в vlan 1 . И так, мы создаем три vlans , в каждом из которых настроена своя ip-область. В vlan 50 входят стационарные компьютеры из сети 50.0.0.0/24 , в vlan 200 входят ноутбуки , на практике этот vlan может использоваться как гостевой или для командировочных рабочих, ip-сеть этого vlan 200.0.0.0/24 , и vlan 100 , в котором находятся серверы web из сети 100.0.0.0/24. Теперь перейдем к конфигурации, с начала добавим порты коммутатора в нужные vlans . Vlan 50 содержит порты fa 0/2, fa 0/3 , fa 0/4. В vlan 200 входят порты fa 0/10 , fa 0/11 , fa 0/12 , а vlan 100 принадлежат порты fa 0/20 , fa 0/21.

Для простоты добавления интерфейсов в vlan используется команда : interface range fastEthernet
после которой нужно дописать диапазон интерфейсов, для которых будут применяться одинаковые настройки.

Switch#conf t
Switch(config)#interface range fastEthernet 0/2-4
Switch(config-if-range)#switchport access vlan 50
Switch#conf t
Switch(config)#interface range fastEthernet 0/10-12
Switch(config-if-range)#switchport access vlan 200
Switch#conf t
Switch(config)#interface range fastEthernet 0/20-21
Switch(config-if-range)#switchport access vlan 100

После добавления портов в vlans , автоматически создается vlan с соответствующим номером.
Чтобы убедиться что порты в нужных vlans используем команду : show vlan

На интерфейс , который подключен к маршрутизатору устанавливаем режим порта как trunk , это необходимо для обмена трафиком между vlans ,в данном случае это interface fa 0/1.

Switch#conf t
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk

Посмотреть какие интерфейсы находятся в режиме trunk можно с помощью команды
show interfaces trunk

Устанавливаем настройки стека на каждом устройстве , подключенном к коммутатору соответственно адресной схеме, имеется ввиду ip-address и шлюз по умолчанию . Шлюз должен соответствовать адресу на определенном sub-interface маршрутизатора.
Проверяем доступность хостов в одной сети:

За тем проверим что другие сети не доступны, хотя это и так очевидно!

Адресная схема выглядит так :

Для начала включаем физический интерфейс , подключенный к коммутатору командой no shutdown .

Router#conf t
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown

Далее настраиваем sub-interfaces :
Обратите внимание на то что после команды encapsulation dot1Q необходимо указать номер vlan и адрес с той же под-сети что и у оборудования , подключенному к портам коммутатора соответствующего vlan.

Настраиваем sub-interface для vlan 50:

Router#conf t
Router(config)#interface fastEthernet 0/0.50
Router(config-subif)#encapsulation dot1Q 50
Router(config-subif)#ip address 50.0.0.254 255.255.255.0

Настраиваем sub-interface для vlan 100:

Router#conf t
Router(config)#interface fastEthernet 0/0.100
Router(config-subif)#encapsulation dot1Q 100
Router(config-subif)#ip address 100.0.0.254 255.255.255.0

Настраиваем sub-interface для vlan 200:

Router#conf t
Router(config)#interface fastEthernet 0/0.200
Router(config-subif)#encapsulation dot1Q 200
Router(config-subif)#ip address 200.0.0.254 255.255.255.0

Настройка sub-interfaces на маршрутизаторе выглядит так:

На этом конфигурация закончена !
Для проверки откроем web страничку на сервере :

Контрольный пинг в соседние сети :

Ниже приведен сконфигурированный пример для скачки.


Для правильной работы со схемами необходима версия Packet Tracer 5.3.2


Тэги: , , , , , , , , , , , ,



2 Responses to “Маршрутизация между vlans”

  1. Dave 02. Feb, 2011 at 23:09 #

    Картинка к статье “в тему”. Это одна из тем курса CCNA. Подойдет в качестве лабораторной работы по теме InterVLAN Routing. Кстати, дословный перевод “маршрутизатор на палочке” – “router on a stick”.

  2. Гапон Анатолий 02. Feb, 2011 at 23:49 #

    Это не просто картинка – это первый пост , который я написал как CCNA-специалист.

Оставить комментарий


iTuts dakulov Free CDN NetConfig